- wasnlos.ch - https://www.wasnlos.ch/wasnlos -

FRN4Pi V1 Ref008 Testinstallation

Da ich heute bei Zeiten aufgestanden war, und bereits seit einer Weile eine neue Version von FRN4Pi [1] zur Verfügung steht, und mein Bruder bereits einen Raspberry 3 gekauft hat, machte ich mich ‘husch’ daran FRN4Pi V1 Ref008 auf meinem alten Test Raspberry zu installieren.

Zuerst die Einstellungen per http://[IP vom Raspberry]/cfg/v2.conf auf meinen Laptop gesichert, danach die neue Ref008 auf die SD-Karte geschrieben, und den Raspberry eingeschaltet. Der erste Start ging ab wie eine Rakete, von meinem Laptop nun per HTTP auf den Pi eingeloggt, und so erhielt ich diesen Bildschirm zu sehen :

Logon- oder Übersichts-Seite [2]

Da hat sich einiges geändert !
Aber erst mal meine gesicherte Konfigurationsdatei wieder importiert, und mein FRN-Testaccount erschien im Test-Raum von frn.wasnlos.ch !

Da ich vermutete das die Stundenansagen als englische wav’s hinterlegt sind, startete ich den Win-SCP um die wav’s auf meinen Laptop zu laden. Dabei landete ich wie gewohnt im /home/frn Verzeichnis, und darin fand ich weitere Unterverzeichnisse, die allerdings als Links gekennzeichnet sind :

Die Unterverzeichnisse von /home/frn scheinen Links zu sein [3]

Die wav’s vom Verzeichnis hours/ vom Raspberry auf meinen Laptop kopiert, und schnell rein gehört. Wie vermutet sprach da eine Dame die Zeit in Englisch.
Also per Webfront in die Übersicht, den Link bei —>> Hochladen der Audio-Dateien <<— angeklickt, und ich erhielt folgende Seite angezeigt :

Nach dem Anklicken des Linkes --->> Hochladen der Audio-Dateien <<--- [4]

Bei Datei auswählen geklickt, und die Datei error.wav ausgewählt, was auch mit folgender Seite bestätigt wurde :

Die Datei error.wav Datei ausgewählt [5]

Nun Upload angeklickt, und die Seite wurde wieder ohne die ‘error.wav’ angezeigt :

Nach anklicken von 'Upload' [6]

…allerdings eine Bestätigung das es geklappt hat, sah ich nirgens…
So klappte ich das Pull-Down-Menü auf :

Im Pulldown-Menü nichts von meiner error.wav zu sehen [7]

Nichts von meiner error.wav zu sehen :-(
Also wechselte ich wieder zu WIN-SCP, führte einen Refresh durch, doch auch da war nichts in den Verzeichnissen zu finden :

Aber auch darin ist nirgens meine error.wav zu finden [8]

Hab keine Ahnung wenn überhaupt, und wo meine error.wav gelandet ist :roll:
So wie es aussieht kann im WEB-Front auch nicht angegeben werden in welches Verzeichnis (sounds/ oder hours/) der Upload geht.
Daher wieder zu WIN-SCP gewechselt, und hier versucht die error.wav ins Verzeichnis sounds/ zu kopieren. Doch wie im folgenden Screenshot zu sehen schlug auch das fehl :

Versuch die error.wav per SCP auf den Raspberry zu laden scheitert [9]

Da ich das ganze eh mit einem uralt Raspberry Pi getestet habe, und wohl in nächster Zeit kaum ein weiteren Gateway machen will, breche ich das weitere Testen an dieser Stelle ab.

7 Kommentare (Öffnen | Schließen)

7 Kommentare Empfänger "FRN4Pi V1 Ref008 Testinstallation"

#1 Kommentar von Aschi am 18. Oktober 2016 @ 10:54

Was ich in den letzten Monaten von weiteren Personen gehört habe, die einen Raspberry Pi 3 und die V1 Ref008 vom [10] montiert haben, stimmt mich kritisch.
Scheinbar gibt es Probleme den eingebauten W-Lan Adpater richtig zu konfigurieren damit er auf das eigene W-Lan-Netz zugreift.
Von meiner Seite kann ich da nicht weiter helfen da ich keinen RASPI 3 mein eigen nenne…

Zudem bin ich mir nicht sicher ob ich mein Projekt das FRN mit einem Raspberry Pi zu betreiben noch weiter verfolgen werde.
Mir fehlt bei diesem Projekt die Möglichkeit der DTMF-Steuerung (z.B. um den Raum zu wechseln).
Zudem zeigt meine Erfahrung das ich was die Modulation angeht, die Einstellungen auf einem Windows-Rechner viel besser einstellbar sind, als auf dem RASPI.

#2 Kommentar von Toasi am 19. Oktober 2016 @ 21:57

Genau die selben Probleme habe ich, allerdings mit dem Raspi b+ und Ref008 Die Wlan Schlüssel Wurden nicht übernommen. Weder bei der Erstinstallation, mit der wifi.txt, noch nachträglich über das WI. Obs Am WPA2 Liegt ? Jedenfalls scheint das Kennwort auf 8 zeichen begrenzt. Mit den Souds Das selbe… Steht alles auf “read only”. Weiß leider auch nicht weiter :(

#3 Kommentar von Toasi am 20. Oktober 2016 @ 02:52

Nachtrag, ich weiß nicht wieso. Aber wenn man bei der Auswahl der Soundfiles die zum Upload gewünschte Datei ausgewählt hat und man dann ca. 10 Sekunden wartet, dann erst Den Upload Button drückt, erscheinen die Files schon mal im Dropdown.

#4 Kommentar von Zeta 71 am 20. Oktober 2016 @ 08:48

Hallo Toasi
Beim W-LAN kann ich dir evt weiterhelfen. Formatiere deine SD Karte im Format FAT32. Wenn du die .iso Datei wieder auf deine SD-Karte geladen hast, beschreibe beiden WIFI Texte mit deinen Daten, Neztwerk und Passwort.
Ich hoffe dir damit weitergeholfen zu haben, liebe Grüsse Thomas

#5 Kommentar von Toasi am 20. Oktober 2016 @ 16:23

Hallo Zeta 71,
Genau das habe ich gemacht, Aber es kommt immer kein Passwort dabei raus, Er nimmt es einfach nicht. Auch im Wi nicht ich dnke es liegt daran das es 63 Zeichen mit Sonderzeichen lang ist. Mir ist aufgefallen das immer nur die ersten 8 oder 16 Zeichen stehen bleiben, wie bei WPA. Bei meneim Passwort ist am ende |- wobei das – dann in einer Neuen Zeile erscheint.
Geht also bei mir nicht.

Übrigens muss ich mein Tipp mit den Soundfiles revidieren, war wohl zufall. Geht jetzt nicht mehr mit warten. :(

#6 Kommentar von Funki am 7. Februar 2018 @ 18:49

Also die Schreibrechte hab ich bekommen endlich,wenn du bei Putty einfach rw eingibst,dann schreibt es die wav sounds in Verzeichnis.

NUR…..!!!!

Ich kann dann auch auswählen welchen Sound ich möchte,über die Web Oberfläche……aber es spielt die Sounds als Rogerpeep nicht ab.
Einstellen kann ich was ich möchte,wird nicht abgespielt.

Dafür ertönt ein Sound der noch nicht mal im Verezeichnis ist!!!

Alles sehr seltsam.

#7 Kommentar von Jürgen Zetzmann am 13. Juli 2019 @ 14:54

Moin aus dem Hohen Norden GER. Kiel-SH

Es gibt in absehbarer zeit einen neuen FRN-Clienten in C++ Programmiert auf einem Raspi ist aber noch Alfa aber V3 schon.
Externes LCD mit wlan gibt es jetzt schon kann mann mit PICQ benutzen.Kann leider keine Bilder hoch laden.
Aber auf 1a-Funkfeuer auf FB ist einiges zusehen.
Stefhan S. sagte mir ihr kennt euch.
gruß Zetzi