FRN-Gateway mit Raspberry Pi und PiCQ

! In diesem Beitrag geht es um meine Erfahrungen mit dem Raspberry Pi 3 (und 2 !) mit dem, für mich neuen, Projekt PiCQ von Michael !

Auf dieses “neue” Projekt bin ich aufmerksam geworden als am von einem “Michael” der verlinkte Kommentar auf meiner WEB-Seite schrieb.
Selbstverständlich schaute ich mir die unter seinem Namen verlinkte Webseite an !
Aha ein Raspberry Projekt bei dem es nun anscheinen auch möglich ist auf der HF-Strecke mit DTMF den Raum (und noch mehr !) zu wechseln ! Daran bin ich natürlich interessiert, aber am selben Tag unternahm ich noch nichts.

Am Abend um 22:04 erhielt ich auf eine meiner E-Mailadressen ein Mail vom anscheinenden Entwickler “Michael” des PiCQ-Projektes. Da mein Tag/Nacht Rythmus eh ein wenig durcheinander war, schrieb ich am 05.02.2018 morgens um 01:25 Uhr eine Antwort auf dieses Mail. Darin auch ein paar Fragen von meiner Seite, bevor ich mich intensiver mit diesem Projekt beschäftigen wollte. Den ich selbst hab in meinem Funkanhänger noch immer ‘nur” einen Raspberry Pi 2 stehen, und da noch nicht ganz klar war ob dieses Projekt auf diesem funktioniert, hatte ich es noch immer nicht eilig.
Schrieb aber an ein paar Kollegen ein E-Mail das Sie sich dieses Projekt mal ansehen sollten.Der restliche Tag verlief dann eher gemütlich, natürlich schaute ich immer mal nach ob ich vom Michael bereits eine Rückantwort erhalten habe, was leider nicht der Fall :-(

Gestern den 06.02.2018 weckte mich der erste Telefonanruf um ca. 8:15 Uhr. Eigentlich bin ich um diese Zeit bereits auf, da mein Tag/Nacht Rythmus wie bereits erwähnt ein wenig durcheinander ist und ich erst um 4 Uhr in die Heia ging, war dies nicht der Fall.
Dem Anrufer war überhaupt nicht recht das er mich geweckt hatte, doch ich hoffe das ich Ihn wieder beruhigen konnte, den ich hatte Ihm selbst gesagt das ich jeweils ab 7 Uhr auf bin. Mit ihm zusammen sahen wir uns eine Sache um das Thema Packet-Radio an, was gute zwei Stunden dauerte.
Unzählige male klingelte während dieser Zeit mein Festnetzanschluss. Auch wenn ich sah wer es war, kann ich nicht zwei Gespräche gleichzeitig führen.
Also “First in – First Out” !

Als die erste Sache erledigt war, mussten erst mal ein paar “Ämtchen” ums Haus erledigt werden, bevor ich den Rückruf zum zweiten Anrufer startete.
Hier erfuhr ich das Edi (Nova 79) um kurz vor Mittag mit seinem “Holztop” bei mir vor der Tür stehen wird.
“Holztop” ?

Edis Holztop mit Raspberry Pi 3, Display und Tastatur

“Holztop” = Holzschachtel mit einem Rapberry Pi 3, Farbdisplay, Tastatur und Soundkarte

Da könne ich schnell das Image von dem neuen Projekt drauf machen.
Und so stand er tatsächlich kurz vor Mittag mit diesem “Holztop”, Stationsantenne und weiteren CB-Utensilien vor der Tür.
So ging es dann, v i e l zu spontan für mich, daran mir diesen Teil des PiCQ-Projektes durchzulesen, und das Images herunter zu laden, und auf die Speicherkarte zu Flashen.
Gross war die Spannung als der Raspi wieder gestartet wurde ?
Auf dem Raspi-Display sah soweit alles bestens aus, daher per Browser von einem Windows PC auf den Raspi zugegriffen, erhielten wir die ansprechende Oberfläche angezeigt.
Danach war das einrichten des ersten Gateway’s angesagt, was auch wie am schnürchen klappte, und der Gateway auf unserem Server frn.wasnlos.ch im Raum Deutsch zu sehen war. Auch das umschalten auf den “ein Gateway Betrieb” fanden wir hier :

Ein oder zwei Gateway-Betrieb im PiCQ einstellen

Da ich vom Kollegen vernommen hatte das wir heute noch einen Standpunkt für einen Gateway besichten und wegen Erreichbarkeit per CB und Mobile-Internet besichten sollten, dachte ich das es dass mal für den Anfang gewesen sei.
Aber irgendwie hatte ich das Gefühl das der Edi noch mehr testen wollte :?:
Als er dann meinte das in einer Ecke mein Gateway Baldingen liefe, und man das Interface und doch nur am Raspi einzustecken bräuchte, wusste ich das er noch nicht gehen wollte 8-)
Nach einigem intervenieren meinerseits liess ich mich breitschlagen, und der “Holztop” wurde in nähe des Gateway’s umgezogen. USB-Stecker und die beiden 3,5mm Klinkenstecker vom Interface an den Raspi angesteckt, wurde dieser abermals gestartet.
Handgurke gepackt, und mal dumm reingerufen ?
Nichts passierte, weder das man im PC-Client auf meinem Laptop das gesprochene wieder raus labbern hörte, noch erhielt ich auf die Handgurke einen Rogerpiep :?:

Schnell bemerkte Edi das bei den Einstellungen für Gate 1, unter Audio auf der linken Seite etwas anderes stand als auf der rechten Seite :

Audio Hardware für Gate 1 im PiCQ einstellen (Standart = Falsch)

Frech und unbekümmert wie er ist kopierte er das was auf der rechten Seite stand, rüber auf die linke Seite :

Audio Hardware für Gate 1 im PiCQ einstellen (Von rechter Seite kopiert = Richtig)

Nach einem Neustart des Raspi’s als dieser wieder in der FRN-Liste stand, griff ich abermals zum Handfunkgerät. Nun hörten wir mein gesprochenes auch aus meinem Laptop sprechen, aber ein Rogerpiep war auf dem Handfunkgerät nach dem loslassen der Sendetaste war nicht zu hören.
Ein Blick auf das PiCQ Web-UI, sah ich unter Radio folgendes :

Radio bezw. PTT-Tastung für Gate 1 im PiCQ einstellen (Standart = Falsch)

PTT-Tastung mittels eines PIN’s am Raspi, das kann nicht stimmen ! Aber wo seh ich nun was ich da eingeben muss ?
Obwohl ich von Audio auf Radio gewechselt hatte waren rechts noch immer nur die Einstellungen für die Audioanschlüsse zu sehen. Luxus wär gewesen wenn da auch der Anschluss für das Interface zu sehen gewesen wären ;-)
Aber mir kam da bereits eine Idee, schnell raus in den Funkanhänger meinen Raspi 2 einschalten der mit einem älteren Projekt läuft, per Browser dann gesucht was dort drinn steht, und dies hier eingetragen :

Radio bezw. PTT-Tastung für Gate 1 im PiCQ einstellen (Für Sturzvogel FFN V2.0 = Richtig)

Auch das COS (Funkgerät an Pi) übernommen, und abermals den Raspi neu gestartet.
Nach dem Test klappte dann auch die TX umschaltung und wir erhielte den von uns erwarteten Rogerpiep zu hören :lol:

Zwar auf beide Seiten noch ein bischen leise, darum ging es auf die Mixer Einstellungen :

Komische Darstellung bei den PiCQ Mixer Einstellungen

Obwohl eine USB-Soundkarte angesteckt ist, und diese auch mal leise funktioniert ist hier alles leer :?:

Da es aber auch Edi nun auf Achse zog brachen wir hier für heute soweit ab, und machten uns auf Tour. Unterwegs erhielt das Auto noch was zu drinken, Edi kaufte am Tankstellenshop aber auch Sandwich und was flüssiges (Danke).
Nach einem Autowechsel bei ihm zu Hause ging es weiter zum vielleicht zukünftig zu Hause des Raspi 3 mit PiCQ welches wir gerade testen.
Der neue Platz wurde als OK befunden, danach war mittlerweile noch ein anständiges Abendessen fällig wozu mich Edi einlud (Danke für dieses feine und währschafte Z’Abig)

Nachdem mich Edi wieder nach Hause gebracht hatte, checkte ich ein weiteres mal ob vom Michael vielleicht Post gekommen war.
Leider noch immer nichts, obwohl wir bereits einige gestellte Fragen mittlerweile selbst klären konnten, leitete ich meine Mail zum zweiten mal an Michael weiter. Diesmal allerdings von einer weiteren E-Mailadresse meinerseits, in der Hoffnung das diese nicht wie vielleicht die erste im Spam landete ?
Den was steht da schon wieder auf der PiCQ-Seite ?

E-Mailadressen für FRN-Client's

Genau ;-)
Noch mit meinem Zusatz : Guckt auch mal in den Junk/Spam Ordner !

So das wars mal soweit, aber es geht bestimmt noch weiter…


Kommentare

FRN-Gateway mit Raspberry Pi und PiCQ — 22 Kommentare

  1. Da ich bereits am Donnerstag 08.02.2018 auf dem Raspberry eine grafische Benuteroberfläche und Teamviewer installiert hatte, gab ich dem Michael die Zugangsdaten für den Raspi mit PiCQ an. Somit konnte er bereits am selben Tag das Problem mit dem weissen Bildschirm beim Alsamixer beheben :

    Nach dem Zugriff von Michael auf unseren Raspi sieht nun die Alsamixer Seite OK aus

    Dazu erhielt ich von Ihm folgende Mail :

    Bei der Änderung gestern Abend habe ich den Mixer also als Root gestartet. Ich habe dem Root nun aber gesagt, er solle nur für den Mixer, so tun als währe er Benutzer „Pi“. Damit darf der Root nun auch auf die Konfigurations-Datein zugreifen die eigentlich „Pi“ gehören und für ihn gesperrt wären. Bei Linux ist das Absicht, damit der Root zum Beispiel nicht dir den Ton leiser machen kann ohne das Du das erlaubt hast. Durch diesen Trick haben wir es dem Root aber erlaubt, und der Mixer wird nun angezeigt. In der CLI ist das nicht nötig, da dort der Root der einzige ist, der aktiv angemeldet ist, bei dem GUI jedoch meldet sich ja Pi an.

    Besten Dank an Michael.

  2. Bereits am Freitag den 09.02.2018 leistete ich die ersten Handarbeiten für den neuen PiCQ Gateway :

    Bereits am Freitag 09.02.2018 die ersten vorarbeiten für den PiCQ Gateway geleistet

    So musste an der RAKO-Box die 12 Volt KFZ-Buchse entfernt, und durch eine 240 Volt Gerätebuchse getauscht werden. Am Holzeinsatz wurde das Netzteil, Funkgerät und der Raspberry 3 soweit montiert.

    Heute ging es daran die ganze Verkabelung der einzelnen Geräte zu montieren. Doch bereits beim ersten Gerät musste ich feststellen das die Überlegungen von Freitag nicht ganz passten. Den als ich am Netzteil den Gerätestecker in die dafür vorgesehene Buchse steckte, musste ich das Netztei soweit nach oben schieben das der Deckel nicht mehr zugegangen wäre :oops:
    Irgendwo hatte ich im Haus doch mal ein Anschlusskabel mit abgewinkeltem Gerätestecker gesehen ?
    Nach über einer halben Stunde ohne Erfolg, gab ich die Suche auf :twisted:
    Während eines Telefonats kam mir eine Idee :idea:
    Da ich die Holzkonstruktion aus Tischlerplatten mit einer Dicke von 3 Zentimeter zusammengebastelt hatte, sollte es doch möglich sein mit der Sticksäge im Boden eine Aussparung auszusägen ?
    So wie ich das in blauer Farbe auf folgendem Bild eingezeichnet habe :

    Netzteil wegen geradem Netzgeräteanschluss zu hoch oben

    :lol: Es klappte :lol:
    Danach ging es weiter, und bis auf den Mobile-Internetrouter der wohl am besten ausserhalb der Box sein Platz finden wird, sind alle Teile soweit miteinander “verdrahtet” :

    Die Komponenten für einen Gateway mit PiCQ in der RAKO-Box

    Mit geschlossenem Deckel sieht das von oben dann so aus :

    Der PiCQ Gateway von aussen

    Klar zu sehen der PL-Anschluss für die CB-Antenne.
    Die RAKO-Box geschnappt und raus in meinen Funkanhänger verfrachtet, 240 Volt Anschluss eingesteckt und die Antenne angeschlossen :

    Der PiCQ Gateway mit Stromversorgung und angeschlossener Antenne

    Soweit steht der Gateway mal bereit :

    PiCQ Gateway im Funkanhänger...

    Noch die Funkantenne aufgebaut und auf den Mast “gepfropft” :

    ...und Antenne am Funkanhänger bereit für die nächsten Test's

    können wir nun die weiteren Test’s absolvieren…

  3. Abends nach dem QRL machte sich Edi an die Verbesserung der Einstellungen um die Audioqualität.
    Nach unzähligen Versuchen und vergleichem mit meinem Gateway Baldingen, welcher mittles Windows und Original-FRN-Client als Referenz herangezogen wurde, war es nach etwas mehr als einer Stunde geschafft.

    So sehen unsere Einstellungen für die “PiCQ Einstellungen Gateway1″ unter “Audio” wie folgt aus :

    Unser Einstellungen bei 'PiCQ Einstellungen Gateway1' unter 'Audio'

    Auch im ALSA Mixer wurden Einstellungen verändert, womit es nun wie folgt aussieht :

    Unser Einstellungen des 'ALSA Mixers'

    Der Equalizer im ALSA Mixer wurde mit folgenden Einstellungen gefüttert :

    Unser Einstellungen des 'Equalizer' im 'ALSA Mixer'

    Vielleicht noch erwähnenswert die Einstellung des Sturvogel USB-INTERFACE FFN V2.0, daran sind beide Regler auf “0”, also in mittelstellung.
    Am verwendeten Funkgerät CRT Megapro ist der Volumeregler auf “halbzehn”.

    Der Gateway mit dem PiCQ bleibt für weitere Versuche 24 Stunden bei mir zu Hause Online.

  4. Nachdem Edi’s zukünftiger PiCQ-Gateway im Anhänger vor sich hin läuft, machte ich mich am Abend vor 2 Tagen daran das Projekt PiCQ auch auf meinem Raspberry Pi II in meinem Funkanhänger zu installieren.

    Das ganze ging flott von der Hand und schnell war der FRN-Account erstellt und weitere Einstellungen getätigt.

    Bis auf den ALSA-Mixer der auch hier, diesmal ohne grafische Oberfläche zu installieren, wieder nur einen weissen Hindergrund zeigte :

    ALSA-Mixer Bildschirm auch beim Raspberry II nach neu Installation weiss

    Also hab ich dem Entwickler von PiCQ, dem Michael eine Mail geschrieben.
    Und erhielt folgende Antwort zurück :

    Hallo Aschi
    Logge dich bitte mit mit SSH auf dem Raspberry ein.
    Wechsele danach zum Benutzer Root indem Du folgenden Befehl eingibst:

    sudo -s

    Nun solltest Du als Root angemeldet sein. Der neue Versuch beruht darauf, dem Alsa eine Standart-Soundkarte vorzuschreiben. Dazu erstellst Du mit einem Editor (ich habe dafür „Nano” in PiCQ installiert) eine Datei die an einen bestimmten Ordner muss.
    Der komplette Befehl dazu lautet also wie folgt:

    nano /etc/asound.conf

    Wenn Du das eingegeben hast, öffnet sich das leere Fenster von Nano und dort kopierst Du folgenden Inhalt rein, oder schreibst es ab:

    pcm.!default {
    type hw
    card 1
    }

    ctl.!default {
    type hw
    card 1
    }

    Du kannst nun Nano einfach mit der Kombination [STRG] + [x] beenden. Wenn man dort etwas neues eingetippt hat, fragt Nano beim Beenden automatisch ob man speichern möchte.

    Danach kannst Du den Raspberry mit dem Befehl reboot einfach neu starten.

    Dies sollte das Problem auch lösen.

    73, Michael

    Gelesen und das ganze ausgeführt, erschien im ALSA-Mixer nach dem Neustart :

    ALSA-Mixer nach den angegeben Änderungen und nach Neustart

    :lol: Das PiCQ funktioniert auch auf dem Raspberry Pi II :lol:

    Danke Michael dem Entwickler vom PiCQ.

    Ich bin froh das ich nun in meinem Funkanhänger einen Gateway hab mit dem ich die Räume wechseln kann :lol:

  5. Nichts zu danken. Im Gegenteil, ich danke dir für dein Feedback. Nur so kann ich Verbesserungen einbauen und Fehler beheben, die sich in meinem Setup nicht ergeben. -Ja und ich habe mir nun angewöhnt auch selbst wenigstens 1 mal am Tag in den Spam-Ordner zu schauen. ;-)

    Viele Grüße und danke für das schöne QSO heute Abend.

    64 +/-9 (55&73), Michael

  6. Hallo Aschi,

    es wird dich sicher freuen, dass ich bei der Weiterentwicklung an dich gedacht habe. Ich bereite gerade ein weiteres Update vor, mit dem PiCQ nun auch den aktuellen Server/Raum per Sprache an seinen Funker mitteilt.

    Dabei stehen dem Benutzer auch noch 2 verschiedene Arten zur Verfügung, wie die Ansage erfolgt:

    1. PiCQ liest diese Informationen selbst aus der Verbindung aus, und sagt sie mittels eingebautem Sprachsynthesizer selbst an.

    oder

    2. Es gibt eine Freigabe “net” auf PiCQ. Dort kann man selbst seine .wav Dateien erstellen, die dann von PiCQ abgespielt werden, wenn der betreffende Raum verbunden wird. Dabei muss der Name der .wav-Datei jedoch unbedingt so geschrieben werden, wie der Raum auch auf dem Server geschrieben ist. (Z.B. bei meinem Stamm-Raum “Berghütte” muss die Datei dann auch “Berghütte.wav” genannt werden. -Findet PiCQ diese Datei nicht, weil sie entweder nicht da ist, oder falsch geschrieben wurde, sagt es eben einfach “You are connected.” damit man wenigstens weiss das der Raum gewechselt wurde.

    Ich habe die notwendigen Dateien bereits bei mir getestet und auf meinem Setup läuft es fein. Jetzt bin ich gespannt, wie es auf anderen Systemen arbeitet. -Das Update werde ich bei Gelegenheit auf der Seite von PiCQ bereitstellen. (rc2_update3)

    73, MiCKi9; Michael

    • Salü Michael

      Erstmal Danke für Deinen Kommentar den Du hier hinterlegt hast. Und natürlich auch für das neueste Update, und die dahinter steckende Arbeit.

      Gestern schlief ich mal wieder bereits um ca. 20 Uhr auf dem Sofa ein :-(
      Dadurch war ich aber um 3 Uhr heute morgen wieder auf. Und es liess mir natürlich keine Ruhe die Sache anzugehen.
      Aber erst musste ich mich überhaupt mal mit der Update-Funktionalität vertraut machen. Den ich hatte anno dazumal nur einfach das Hauptimgages geflasht, und einen grafischen Desktop und den Teamviewer installiert. Danach noch ein paar Problemchen mit Dir zusammen gefixt, und da war soweit mal Schluss.

      Da aber die RAKO-Box des Kollegen noch immer bei mir in der Stube steht, habe ich es mit Deiner Anleitung zügig geschafft das Update “rc2_update1″ und “rc2_update2″ auf den Raspberry III zu kriegen !

      Danach war dann Dein neuestes Update “rc2_update3″ an der Reihe.
      Hier gefror mir dann allerdings das Blut in den Adern als ich da was von “Teamviewer” auf der Console “durchflizen” sah ?
      Geht danach der Teamviewer mit meinen Daten noch ?
      Den ich hatte noch kein komplettes Images von der SD-Karte gezogen, gegenüber meinen üblichen Gepflogenheiten.

      Aber meine Befürchtungen waren unbegründet als ich nach dem Update den Raspberry auch noch neu startete, (fast) alles wie gewohnt, auch mittels Teamviewer konnte ich mit meinen Daten darauf zugreifen.
      Das fast in Klammern meine ich im positiven Sinne, den auf dem PiCQ-Desktop sah ich das neue Icon “Messages” :

      Nach Update 'rc2_update3' neues Icon 'Messages' auf PiCQ-Desktop

      Auch wenn ich mir im momentan noch nicht vorstellen kann was es mit diesem Icon auf sich hat, klickte ich es an, aber ausser einem fast leeren Bildschirm sah ich da nichts. Aber werde zu einem späteren Zeitpunkt sicher herauskriegen was es damit auf sich hat.

      Seit Anfang als ich das Projekt PiCQ entdeckte und installiert habe, wurde von mir im Windows zugänglichen Verzeichnis “\sounds\” bereits ein Unterverzeichnis Namens “NetNames” erstellt :

      Schon seit Anfang habe ich das Verzeichnis 'NetNames' im PiCQ angelegt...

      und da hinein die bereits aus dem PC-Clienten für Windows vorhandenen WAV-Dateien für meinen Server frn.wasnlos.ch hineinkopiert :

      ... und darin die WAV-Dateien analog zum FRN-Clienten auf Windows

      Da es mir aber im Moment mit dem vorbereiteten Gateway wegen “höheren Umständen” nicht möglich ist den Raspberry auch am Funkgerät zu betreiben, muss das weitere Testen auf später verschoben werden.

      Aber sieht soweit schon mal gut aus :lol:

      Michael, Du schreibst das die WAV-Dateien den selben Namen wie die Raumnamen haben müssen !
      Wie sieht das bei PiCQ mit Leerzeichen (Space), und der unterscheidung GROSS/klein aus ?
      Den beim Windows-FRN-Clienten hatte ich da öfters Mühe das hinzukriegen, und Leerzeichen verträgt er im Dateinamen auch nicht.

      Update vom 01.04.2018 um 11:00 Uhr

      Da es mittlerweile hell wurde, und ich eh nach draussen musste war es Zeit die Hosen anzuziehen ;-)
      Nachdem die Hühner ihren Salat gekriegt haben, schaltete ich im Funkanhänger meinen Raspberry PI II ein, um auch da die 3 Updates zu installieren.

      Dabei merkte ich das das neue Icon “Messages” nichts mit dem Update “rc2_update3″ zu tun hat ;-)

    • Hallo Aschi,

      nein, keine Sorge an deinem Team-Viewer sollte sich nicht viel geändert haben. Da ich nach dem Update, innerhalb PiCQ, auf ein neues Programm namens “sox” zugreife, war es nötig dies im Zuge des Updates zu installieren. Naja und wenn ich schon eine Software dazu installiere, lasse ich den Raspberry natürlich auch gleich seine Paketquellen aktualisieren. Dies schließt natürlich auch die Paketquellen deines Team-Viewer mit ein.

      Und ja, die Message-Funktion hat nichts mit dem Update 3 zu tun. Diese kam bereits mit dem Update 2. ;-)

    • Ps. Im Message-Fenster erscheinen alle Textnachrichten, welche deine Gateways seit Systemstart empfangen haben. Also Nachrichten an den jeweiligen Raum, und private Nachrichten. Ich habe mich bemüht, dass auch die Textformatierung von Edwin’s FRN übernommen werden. Also wenn jemand dort etwas in kursiver Schrift schreibt, oder unterstreicht, wird es auch hier so angezeigt. Da man ja 2 Gateways betreiben kann, steht in der Kopfzeile auch jeweils über welches Gateway die Nachricht kam.

      • Hi Michael,

        ich hab PiCQ auch im Einsatz, Danke dafür :) Da ich im Wiki keine Kontaktmöglichkeit zu Dir gefunden habe Hier noch ein Tip für die Parameter Light und Static … soweit ich im Bilde bin können da VOX Werte für Light(Träger ohne Modulation) und Static (Träger mit Grundrauschen) eingetragen werden.
        Ich bin der Meinung das dient dazu eine Ein-/Ausschaltkurve für das VOX zu bilden um Aussetzer zu unterbinden.

        Viele Grüße, Axel

    • Nachdem mich heute morgen um 8 Uhr die Sonne mit ihren Strahlen geweckt hatte, ging ich heute daran die Sprachansage für den Server- und Raumnamen zu testen.
      Also husch an meinen Raspi II mit PiCQ ein Funkgerät angeschlossen, und am Funkgerät meine Magnetsockel-Mobilantenne angeschlossen.
      Nun wurde es spannend !
      Erst mal mit folgender Einstellung probiert :

      PiCQ Ansage Server- & Raumname mit Sprachsynthesizer

      Nun an meinem Stabo xh 9600e den “Panasonic Fernabfrage Code-Sender” an das MIC gehalten und die Tasten 4# gedrückt. Und siehe da auf meinem PC-Client verschwand der Gateway aus dem Raum “Wasnlos” (3), und war im Raum “FRN” (4) zu finden :

      1. Versuch der Raum-Ansage im Raum 'FRN'

      Aber vom Funkgerät vernahm ich NUR den gewohnten Roger-Piep Ton den ich konfiguriert habe, NICHT aber eine Ansage ?

      Nächster Test mit der DTMF-Folge “5#” wechselte der Gateway in den Raum “Schopfis”, und ich erhielt über Funk den “Warnton bei keiner Verbindung zum Server (HF)” abgespielt ?

      2. Versuch der Raum-Ansage im Raum 'Schopfis'

      Also wieder die DTMF-Folge “4#” eingetippt, worauf der Gateway in den Raum “FRN” umzog, und ich wieder über Funk den “Warnton bei keiner Verbindung zum Server (HF)” abgespielt erhielt ?

      3. Versuch der Raum-Ansage im Raum 'FRN'

      Komisch warum ich das erste mal den normalen Roger-Piep erhielt und nun das Fehler WAV.
      Aber schlussendlich funktioniert die Ansage mit dem Sprachsynthesizer nicht.

      Bereits seit Anfang habe ich alle Wav-Dateien der Räume für meinen FRN-Server in das Verzeichnis Sounds\NetNames\ kopiert :

      Schon seit Anfang habe ich das Verzeichnis 'NetNames' im PiCQ angelegt...

      daher war es Zeit in der Konfiguration auf “Wave- Datei” um :

      PiCQ Ansage Server- & Raumname mit WAV-Datei

      Und startete den Versuch mit der Eingabe der DTMF-Folge “5#”, auch da wechselt der Gateway in den Raum “Schopfis”, und ich erhielt über Funk den “Warnton bei keiner Verbindung zum Server (HF)” abgespielt ?

      Da ich auf der PiCQ WEB-Seite nichts gefunden habe (entschuldige Bitte wenn da doch was steht ), wo die WAV-Dateien überhaupt sein müssen, und ich beim installieren eben das “Messages” Icon neu entdeckte, dachte ich erst das das was damit zu tun haben könnte. Was ich wie auf meiner WEB-Seite bei genauerer Betrachtung ja ausschliessen konnte, und Du mir dann mit einem Kommentar auch bestätigt hast.

      So ging ich mit meiner Logik weiter und kopierte die Wavedatei “FRN” mal eben auch ins “sounds\” :

      FRN.wav zum Versuch ins sounds-Verzeichnis kopiert

      Also wieder die DTMF-Folge “4#” eingetippt, worauf der Gateway in den Raum “FRN” umzog, und ich wieder über Funk den “Warnton bei keiner Verbindung zum Server (HF)” abgespielt erhielt ?

      4. Versuch der Raum-Ansage im Raum 'FRN'

      Meine Logik ist somit leider am Ende ;-)

      Dabei hat mir der Dirk in der letzten Nacht noch etwas gesagt das er irgendwo gesehen hätte das die WAV-Deiten irgendwo in einem “Net” Verzeichnis sein müssten aber nicht im “Sounds”.
      Tja rein logischerweise wären die in einem Verzeichnis im “sounds” am besten ?

      Meine Frage weiter noch wegen den Raumnamen, da hast Du geschrieben das die Namen der Wave-Dateien gleich sein müssen wie der Raumname, da der Windows FRN-Client aber mit Leerzeichen Probleme hat müssen die dort weggelassen werden ! Sodass die Wave-Datei für den Raum “Freie Funker Ch” dann eben den Namen “FreieFunkerCh.wav” haben muss.
      Wie sieht das in PiCQ aus ?
      Und wie sieht es mit Gross/Kleinschreibung aus ?
      Weiter kenne ich es beim Windows-Client so das wenn ein Gateway mittels DTMF per HF in anderen Raum gestellt wird, das dieser automatisch wenn im “neuen” Raum 3 Minuten stille herscht, dieser wieder in seinen Raum, der in der Konfiguration :

      PiCQ Server Einstellungen

      angegeben ist, zurück geht. Eine ganz praktische Sache, wie ich finde.
      Was meint Ihr ?

      Tut mir leid das ich keinen besseren Bescheid geben konnte ;-)

    • Nachdem ich die letzten Tage auf 3 Raspberry’s (2 mal Raspi II und 1 mal Raspi III) den Release Version PiCQ v. 1.00 vom 05.04.2018 auf die SD-Karte geflasht, alle Einstellungen angepasst, und auch das Update 1 für Version 1.00 vom 10.04.2018 installiert habe, ging es an’s testen ;-)

      Meine selbsterstellten WAV-Dateien auf die Freigabe “net” kopiert :

      WAV-Dateien für die Raumansgen in die Freigabe 'net' kopiert

      Mein Testkandiat für diesen Kommentar ist ein RaspberryPi II welcher auf dem Server frn.wasnlos.ch im Raum Wasnlos startet.
      In der Konfiguration unter “Ansage Server-/Raumname” natürlich für meine eigenen WAV-Dateien folgendes eingestellt :

      PiCQ Ansage Server- & Raumname mit WAV-Datei

      Und startete den Versuch mit der Eingabe der DTMF-Folge “4#”, der Gateway wechselte in den Raum “FRN”, aber der Raumname wurde NICHT angesagt !

      Da in einem Kommentar bei diesem Beitrag der Josef bestätigte das zumindest die Raumansage mit Sprachsynthesizer bei Ihm funktionierte, versuchte auch diese Einstellungen :

      PiCQ Ansage Server- & Raumname mit Sprachsynthesizer

      Aber auch da wechselt der Gateway in den Raum “FRN”, aber der Raumname wird NICHT angesagt !

      Zudem verschwinden die Raspberry Pi’s II seit ich mit der Release Version PiCQ v. 1.00 von PiCQ arbeite nun nach ca. 24 Stunden aus dem Netzwerk :?: Wie ich das in diesem Kommentar zuerst festgestellt hatte, aber auch mit meinem mobilen Gateway im Funkanhänger reproduzieren kann.

    • Über Pfingsten hatte ich Gelegenheit auch mit einem Raspberry Pi III den Test wegen der Raumansage mit dem Release Version PiCQ v. 1.00 und dem dazugehörigen Update zu testen.

      Doch auch mit dieser Raspi Version war weder vom Sprachsynthesizer noch von meinen WAV’s bei einem Raumwechsel etwas zu hören :-(

      Zum Schluss aber noch etwas positives : Der Abbruch zum Netzwerk per WLan findet mit dieser Raspi Version über mehrere Tage nicht statt, wie ich das bei Test’s mit Raspberry Pi’s Version II feststellen musste.

    • Nach dem ganzen Raspi-Koller nachdem ich einfach keine Lust mehr hatte, habe ich mich vor 2 Tagen wieder aufgerafft, um vielleicht den Fehler zu finden wieso die Raspberry Pi’s II sich mit der neuen Version PiCQ v. 1.00 vom 05.04.2018 einfach “verabschieden”.

      Dabei ist mir beim beobachten unter [Status] aufgefallen das die CPU über 100% ausgelastet wird :?:
      Aus den alten Amiga-Zeiten hatte ich Erfahrungen das dies meist nicht lange gut geht.
      Darum entschloss ich mich es noch einmal zu versuchen, und die SD-Karte ein weiteres mal mit der Version PiCQ v. 1.00 vom 05.04.2018 zu Flashen. Danach noch das Update 1 für Version 1.00 vom 10.04.2018 installiert und fertig. Also nix mehr wie bis anhin mit graphischer Oberfläche und Teamviewer !

      Tja und nun läuft der Raspberry Pi II in meinem Funkanhänger bereits seit etwas mehr als 48 Stunden durch :lol:

      So neben bei, trotzdem funktionert die Raumansage mit keiner der beiden Varianten ;-)

  7. Hallo Aschi,
    nachdem ich die neueste Version + Update installierte funktioniert bei mir die Server und Raum Ansage mit Sprachsyntesizer jetzt perfekt! (RaspberryPi 3)
    Was aber absolut nicht funktionieren will ist der Timer: ich kann schalten und einstellen wie ich will, es tut sich nichts am betreffenden GPIO Port!
    Bei den GPIO`s funktioniert auch nur ein Port…der andere bleibt immer off!
    Die Beschriftung der Ports sowie die GPIO Übersicht auf der Webseite sind ein bisschen verwirrend…das scheint nicht ganz zusammenzustimmen! Aber beim Timer reagiert auch kein anderer Port auf die E/A Befehle!
    Weist Du da Rat od. handelt es sich noch um einen Bug?
    Viele Grüße, Josef

  8. Gestern als ich im Schopf bei meinem Bruder war, um dort als Gast von Venty und Axel vom Hackerfunk, ein Interview zum Thema “Free Radio Network” aufzuzeichen, erhielt ich von Axel die Info das der Link aus Google zur PiCQ WEB-Seite nicht funktioniere !
    Noch während der Aufzeichnung, fand ich bereits eine E-Mail von Dirk im Postfach mit dem Link zur neuen PiCQ WEB-Seite.
    So konnte für die veröffentlichung des Interviews (soweit ich weiss am Samstag 6. Oktober 2018) dies gleich angepasst werden.

    Heute erhielt ich von meiner WEB-Seite bereits die erste Mail über das Kontaktformular, das in diesem Beitrag die Link’s auf die PiCQ Seite nicht mehr funktionierten.
    Richtig, auch da sollte ich natürlich die diversen Links noch anpassen, da doch einige diesen Beitrag lesen und am PiCQ Projekt interesse zeigen.
    Also setzte ich mich dahinter und passte die Links an, vorausgesetzt das ich alle ‘erwischt’ habe sollte die hier nun wieder funktionieren.

    Danke an alle die mir sowohl nicht mehr funktionierende Links auf meiner WEB-Seite, wie aber auch die die mir die neuen Links melden :lol:

  9. Hallo Aschi,

    ja der Wechsel der URL kam sehr unvorbereitet. Zwar hatte ich die Adresse picq.network bereits registriert, wollte sie jedoch anders nutzen. Nun kam mir leider der Anbieter der *.tk Domains in die Quere. PiCQ wurde von mir ja auf einer Subdomain von klicke.tk publiziert. Da ich den Server vor einigen Tagen komplett neu aufsetzte, hatte ich die Webseite auf klicke.tk wegen Nichtgebrauchs nicht mehr neu aufgesetzt. Nun schaut das Team von Dot.TK offensichtlich nach, ob Websites unter den Domains erreichbar sind. Offensichtlich wird diese Sichtung bei dem Saftladen jedoch nicht all zu gründlich gemacht. klicke.tk selbst brachte bei ihnen keine Antwort und auf die Subdomains haben sie nicht geschaut. Also haben sie die Domain gelöscht. Das alleine war schon eine dreiste Angelegenheit. Jedoch um ihren Murks (sorry, aber anders kann ich dieses unprofessionell Verhalten nicht nennen) jetzt noch perfekt zu machen, informierten sie mich erst im Nachhinein über die Abschaltung. Jetzt konnte ich zwar die bereits vorher registrierte neue Domain recht schnell konnektieren, Strato hat das einfach gemacht, jedoch werden dadurch die Links in Google und Co ja noch lange nicht aktualisiert. Bei Wikipedia habe ich den Artikel zum Free Radio Network bereits aktualisiert, und wie ich gesehen habe, wurde die Korrektur auch bereits gesichtet und freigegeben.

  10. Heute machte ich mich daran für meinen Raspberry Pi II im Funkanhänger das Update von PiCQ auf die Version 1.29 zu installieren.
    Da das Update von Michael als Komplettimage angeboten wird, ging es mit Akkuschrauber bewaffnet in den Funkanhänger, um den Raspi vom Tisch zu lösen. Den auch wenn der Funkanhänger in seiner Parkposition neben dem Haus steht, ist es nicht vorgesehen das der Raspi mittels LAN am Netz hängt. Sondern das sich dieser jeweils über WLan die Verbindung, zu Hause über “AschiNet” oder unterwegs auf “AschiNet_Mobil”, automatisch herstellt.
    Nachdem der Raspi im Wohnzimmer sowohl mit LAN und Strom versorgt war, startet ich ihn nochmals mit der alten PiCQ-Version. Den ich hatte auf dieser Seite den Hinweis gelesen, das man über die Samba-Freigabe “\\IP-ADRESSE-RASPI\config\” die Dateien sichern, und nach dem Update in das neue PiCQ V1.29 einspielen kann. Natürlich sicherte ich auch gleich die Wavedateien aus dem Verzeichnis “\\IP-ADRESSE-RASPI\net\” und “\\IP-ADRESSE-RASPI\sounds\“.
    Auch die beiden für die Netzanbindungen zuständigen Dateien bei meinem Raspberry Pi, “/etc/network/interfaces” und “/etc/wpa_supplicant/wpa_supplicant.conf“, sicherte ich.

    Nach dem der Raspi heruntergefahren und vom Strom getrennt worden war, wechselt ich die SD-Karte, und startet ihn mit der PiCQ V1.29. Zuerst wurden die für mich nötigen Dateien von der Sicherung auf die neue Version kopiert. Danach wie empfohlen noch schnell bei den GW1 Einstellungen [Speichern] angeklickt, und zur Sicherheit einen Neustart durchgeführt.
    Nachdem ich mich per Browser zum Raspi verbunden hatte, erhielt ich folgenden Home-Bildschirm angezeigt :

    PiCQ V1.29 Homebildschirm

    Sieht vom feinsten aus, scheint zu funktionieren :lol:

    Natürlich wollte ich die Funktion “Ansage Server-/Raumname” testen, und öffnete die dafür zuständige Einstellung :

    PiCQ V1.29 Einstellungen Ansage Server-Raumname

    Hier ist bei der neuen Version 1.29 nur noch ein Ja oder Nein möglich. Auf der neuen WEB-Seite von Michael fand ich auch nichts wie das weiter konfiguriert werden müsste. Aber beim Kopieren der Sicherungsdateien viel mir im “\\IP-ADRESSE-RASPI\net\” Pfad eine Datei mit dem Namen “connsounds.cfg” auf :

    PiCQ_V1_29 Raumansage Samba-Pfad 'Net'

    Also öffnete ich diese Datei mit Notepad2 um sie mal anzusehen, wodurch anhand der integrierten Erklärungen schnell klar wurde wie das aus zu sehen hat. So änderte ich die Datei für meinen Server ab was nun mal so aussieht :

    # Diese Konfigurationsdatei beschreibt welche Ansagen bezüglich Server und Raum erfolgen soll.
    # Die Einträge folgen alle ZWINGEND diesem Chema!
    # ‘sound_file_name.wav’ bezeichnet den Namen der Sounddatei. Es muss immer der Datei-Pfad mit angegeben werden.
    # Dieser lautet immer: ‘/opt/PiCQ/net/’ (Natürlich ohne die Anführungszeichen.)

    # This configuration file describes which announcements should be made regarding server and room.
    # The entries all CRAWLING follow this chema!
    # ‘sound_file_name.wav’ is the name of the sound file. The file path must always be specified.
    # This is always:’/opt/PiCQ/net/’ (Without the quotes, of course.)

    # server | port | network | sound_file_name.wav
    ##

    frn.wasnlos.ch | | Deutsch | /opt/PiCQ/net/Deutsch.wav
    0qrm.freeradio.network | | German | /opt/PiCQ/net/German.wav

    ### Irgend ein Testraum auf irgend einem Server
    ### any Test network(room) on any server
    ||Admins|/opt/PiCQ/net/Admins.wav
    ||Admin|/opt/PiCQ/net/Admins.wav
    ||Airborne|/opt/PiCQ/net/Airborne.wav
    ||BachtelSpatzen|/opt/PiCQ/net/BachtelSpatzen.wav
    ||D D J Privat|/opt/PiCQ/net/DDJPrivat.wav
    ||Deutsch|/opt/PiCQ/net/Deutsch.wav
    ||Freie Funker Ch|/opt/PiCQ/net/FreieFunkerCh.wav
    ||Freie Funker D|/opt/PiCQ/net/FreieFunkerD.wav
    ||Frn|/opt/PiCQ/net/Frn.wav
    ||German|/opt/PiCQ/net/German.wav
    ||Mitholz|/opt/PiCQ/net/Mitholz.wav
    ||Nautilus 75|/opt/PiCQ/net/Nautilus75.wav
    ||Passaia 75|/opt/PiCQ/net/Passaia75.wav
    ||Peter Privat|/opt/PiCQ/net/PeterPrivat.wav
    ||Plauderecke|/opt/PiCQ/net/Plauderecke.wav
    ||Schopfis|/opt/PiCQ/net/Schopfis.wav
    ||Test|/opt/PiCQ/net/Test.wav
    ||Wasnlos|/opt/PiCQ/net/Wasnlos.wav

    #### Irgend ein Server und/oder Net (Raum). -Hierdurch erfolgt immer eine Ansage, dass zumindest eine Verbindung aufgebaut wurde.
    #### any other server and/or network(room). -This always announces that at least one connection has been established.
    #|||/opt/PiCQ/net/AnsageServer.wav

    Danach wurde der Raspi wieder an seinen angestammten Platz im Funkanhänger montiert, und gestartet. Er verband sich nun wieder per WLan mit dem Internet, und ich konnte die Server- und Raumansage testen.
    Bei einem Raumwechsel mit den DTMF-Tasten am Handfunkgerät, wird mir nun der Raumname angesagt :lol:

    Besten Dank an Michael für seine geleistete Arbeit.

    Höllisch gespannt bin ich noch auf die TNC-Funktionalität mit Direwolf, was ich in nächster Zeit sicher auch noch genauer ansehen werde.

    • Ggf. mußt Du noch die AlsaMixer Einstellungen manuell wiederherstellen. Die werden nämlich nicht in den PiCQ config files gespeichert.
      War bei mir auch so — hatte mich zunächst gewundert, warum die bisher konfigurierten VOX Einstellungen (HF –> FRN) nicht mehr wie gewohnt funktionierten. Das lag aber lediglich an den AlsaMixer Einstellungen, die mit dem neuen Image wieder auf DefaultWerte zuruckgesetzt waren …
      Gruß
      Dirk

      • Tja einmal hatte ich scheinbar den richtigen Riecher, als ich die Dateien vom ‘alten’ PiCQ sicherte machte ich auch einen Snapshot von den AlasaMixer Einstellungen.
        Richtig, ich musste auf der neuen Version die Einstellungen dann auch wirklich nachstellen.

        Aber Danke für den Tip, dann stolpern weitere nicht darüber ;-)

Hinterlasse einen Kommentar zu Michael Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>